Hot Door CORE Forum
setBold doesnt work - Printable Version

+- Hot Door CORE Forum (http://hotdoorcore.com/forum)
+-- Forum: All forums (/forumdisplay.php?fid=1)
+--- Forum: General discussion (/forumdisplay.php?fid=3)
+--- Thread: setBold doesnt work (/showthread.php?tid=142)



setBold doesnt work - subscribe - 06-19-2017 01:46 PM

Just tried myLabel.setBold (true)
The font stays regular (not bold), though myLabel.bold() changes to true.
Has anyone tried setBold?

UPD Forgot to say, this happens in a panel.


RE: setBold doesnt work - Rick Johnson - 06-22-2017 12:26 PM

I just tried this with a copy of the Panel sample and it does bold any label on the panel using CORE 0.7.0 and AI 21 on a Mac.

It also works for me under Windows 10, AI 21, VS 2010. The bold text is only slightly heavier than the regular font, so the difference is kind of subtle.

setBold(true) definitely works for labels on both platforms in dialogs.


RE: setBold doesnt work - garrett - 06-29-2017 04:45 PM

Thanks for posting Rick. I just tested this and it works for me as well, on CORE 0.7.0 and our latest internal revisions.

Could the OP please check which version of CORE is in use?


RE: setBold doesnt work - subscribe - 07-01-2017 07:46 AM

Tried with 0.7, VS2010 SP1 at Win7 SP1 64 bit.
This is original panelsample (with "__docPanelNameLabel.setBold(true)", I checked). Compiled as "AI19 Release", version of Adobe Illustrator is 19.2.1.

docPanelNameLabel seems to be regular (not bold).


[Image: mSxfBvWNQ3ayf7Zt0Mf0Mg.jpeg]



RE: setBold doesnt work - garrett - 07-03-2017 01:25 PM

I tested the panel sample, as you indicated, and it works here.

It's hard to tell from the low resolution of the screenshot you posted, but I don't think the font for "No current document" is the same as "(No document to save)". This suggests to me that your system has the Tahoma font for non-bold widgets, but does not have the Tahoma Bold font for bold widgets (so the OS is substituting another font automatically).


RE: setBold doesnt work - subscribe - 07-03-2017 02:58 PM

Garrett, thnx for your response.
Possibly it's my local problem. Gonna test it.