About   |   Getting Started   |   Downloads   |   Documentation   |   Forum


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C++11, linking with VS2010+ toolset
06-01-2017, 08:30 AM (This post was last modified: 06-09-2017 08:23 AM by garrett.)
Post: #1
C++11, linking with VS2010+ toolset
Hello. I wanted to ask - do you intend to move hdi_core to newer versions of VS? Right now the only way of using hdi_core in newer studios I've found is by setting VS2010 toolset within them which still does not allow to use all of C++11 features. All of my attempts to use newer toolsets resulted in linking errors. Not that it is critical or anything but C++11 support would be nice.
Find all posts by this user
Quote this message in a reply
06-02-2017, 02:37 PM (This post was last modified: 06-02-2017 02:41 PM by garrett.)
Post: #2
RE: C++11, linking with VS2010+ toolset
You've got excellent timing Gaxx. One thing we've been working on is switching all of our projects, libraries, and binaries to Visual Studio 2015. This change will be required by Adobe in the near future anyway, so we want to be prepared (and to help users of CORE to be prepared as well).

Sadly, we are sort of limited internally by the lowest common denominator on both platforms, which will always be the oldest version of the Illustrator SDK we're compiling against coupled with the required environment specs for said version. We would really like to bring some C++11 and C++14 features to CORE, but we just can't until support for older versions of Illustrator is dropped (eventually). CS6 still comprises a substantial portion of the active user base in our metrics, so it will probably be a while before CS6 support goes away. However, CC 2013 is barely used in comparison to CS6, so support for it probably won't last much longer than CS6. Same goes for CC 2014, which will only dwindle in use by the time we can drop CS6.

I suspect this is all due to later versions of CC being available to the user "for free", so most people update to later versions when possible. Users that prefer CS6, though, are probably holding out until they can no longer run it at all. Once CS6 can go, it's likely one or two CC versions can go at about the same time.

In any event, you'll be able to use more modern C++ features in your own code soon, but CORE itself won't be able to for a while.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)