About   |   Getting Started   |   Downloads   |   Documentation   |   Forum


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hot Door CORE 0.6.0 is now available
11-02-2015, 07:04 PM
Post: #1
Hot Door CORE 0.6.0 is now available
This update brings the following changes:
  • New WebView class
  • New UTF-8, UTF-16, and UTF-32 conversion functions
  • Added support for mixed state checkboxes
  • New polygon art drawing functions
  • Many new constructors to create CORE-level objects from AI-level handles/refs
  • CurrentDocument class improvements
  • RadioButtonGroup class improvements
  • Improvements to tool dragging detection
  • Disabled UI scaling on Windows
  • Fixes for flyout entry checkmarks
  • HierarchicalView fixes on Mac
  • UI font fixes on Mac
  • Unicode string fixes on Windows
  • Support for Ai 13, 14, and 15 is deprecated (see below)


Important note regarding ADM support
Our testing with Illustrator CS3, CS4, and CS5 (Ai 13, 14, and 15) in OS X 10.11 (El Capitan) indicates that these older versions of Illustrator are beginning to become unstable. For example, on our test machines, the UI for CS3 does not fully load on occasion, CS4 receives several errors on launch regarding Photoshop import/export plugins, and CS5 crashes on quit most of the time.

Attempting to build a CS3, CS4, or CS5 plugin against our binaries with Xcode 7 is problematic as well (the linker gives an error regarding "compact unwinding", among others; linking can be achieved with the "-no_compact_unwind" option, but crashing at runtime has been observed). While the binaries themselves should continue to function, Xcode 7 cannot be used to develop for these versions of Illustrator (you will need Xcode 4, 5, or 6).

As such, we are officially deprecating support for these versions of Illustrator. As they are the versions of Illustrator still using ADM for plugin UI, we will cease further development of ADM-related features and only fix major bugs regarding these versions. When CORE reaches version 0.7.0 we will officially drop support for these versions of Illustrator and stop compiling our binaries for them.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)